OmniPresent Supported Browsers and System Requirements

Supported Web Browsers

Microsoft Internet Explorer 8.0 & up

Google Chrome 4.0 & up

Firefox 1.5 & up

Safari 1.x & up

System Requirements

Operating Systems

Microsoft Windows XP & Up
MAC OS X 10.4 and Up (desktop sharing not supported for presenters)
Android if browser supports flash 10.1 & Up or install the Web Conference Mobile app from the Android Market
IOS (iPad and iPhone 4 & Up.)

Additional notes: All mobile apps for the web conference are for attendees only. Presenters should use a laptop or desktop computer.

If you choose to run the web conference with an unsupported operating system, it may work but our support team will be unable to solve any issues you may experience.

Plugins (not required on mobile devices)

Adobe Flash Player 10.3 or later – Only released Flash Player versions are supported. Do not use alpha or beta versions. Get the latest version of Flash Player HERE.

Internet Connection

These are the MINIMUM requirements. We recommend you use hard wired connections to minimize bandwidth fluctuations that can cause audio/video breaks. Click HERE to learn more. Please consult with the web conference technical support team for more information on the impact of advanced usage and bandwidth requirements.

Hardware

Keyboard and Mouse or compatible pointing device
Speakers
Microphone (If using Voice)
Web Cam (If using Live Video)